It is currently 24 Sep 2018, 02:34




This topic is locked, you cannot edit posts or make further replies.  [ 4 posts ] 
[SOLVED] v1.1 game launching problem 
Author Message
Ex-MYT
User avatar

Joined: 09 Jun 2007, 07:34
Posts: 439
Steam: srxviper
I have not played v1.1 on my PC with Windows 7 installed, but TSS plays alright without problems. Whenever I attempt to launch v1.1, the screen will go black, with a mouse cursor that goes "+" until I move it around, which then will return to the arrow pointer. The screen will remain black with nothing going on, the drive not spinning, etc. for minutes. When I attempt the CTRL+ALT+Del keys, I can get back to the desktop and there is this error message on the screen:

-------------------------------
No Label

Crash Time: 03/20/14 20:28:37

OS: Windows XP 5.1 (Build: 2600)
CPU: GenuineIntel PentiumPro-class processor @ 3293 MHz with 1023MB RAM
Video: ATI Radeon HD 3800 Series (1129)

UserName: Viper
ComputerName: ViperPC
Application location: C:\Program Files\Sierra\SWAT 4\Content\System\

SWAT Build Number: 34688

Error setting display mode: CreateDevice failed (D3DERR_INVALIDCALL). Please delete your Swat4.ini file if this error prevents you from starting the game.

History: UD3DRenderDevice::UnSetRes <- CreateDevice <- UD3DRenderDevice::SetRes <- UWindowsViewport::TryRenderDevice <- UWindowsViewport::OpenWindow <- UGameEngine::Init <- InitEngine

-----------------------------------------------------------------------------------

I have tried deleting the Swat4.ini file, reinstalling the game a few times. Nothing worked so far.

I was wondering if this has anything to do with the fact that my monitor runs at 1440x900, which is not the 4:3 ratio that the game was designed on? What baffles me is that I can run TSS without problems (SP or MP modes).

Or is it Direct3D, which seems to be what the error code "D3DERR_INVALIDCALL" suggested?

Any ideas?

TIA.

_________________
Image
Image
Image


21 Mar 2014, 06:47
Profile
Senior Member
User avatar

Joined: 13 Mar 2011, 23:02
Posts: 678
I used some variants around a simple query on a well-known search engine.

The best answer I could find suggest that if the original SWAT4.ini file content doesn't make the game working, the problem does not come from the game itself but rather from its environment.

Specifically pointed out, the ATI (now AMD) drivers seem to be the root cause.
Try to unistall/reinstall them.

If that does not work, someone having a close (but not the same problem, look at the Direct3D error code) spoke of using some Omega drivers.
I do not know what that is worth, nor do I generally trust third-party (not vendor ones) drivers...

One thing is for sure to me: that is a driver-related problem rather than a game one.

_________________
Beerbelott
Image
Image
All my potential profiles (several moves, either physical or IP-based)


21 Mar 2014, 18:59
Profile
Ex-MYT
User avatar

Joined: 09 Jun 2007, 07:34
Posts: 439
Steam: srxviper
Thanks for the suggestions, Beer. :)

The video card driver I had installed is the only version available officially for my card. I searched around the net for an older version and I found an old one which works with both v1.1 and TSS.

The video card I am using is actually a back-up. The previous one (HD7850) did not seem to like my motherboard. I will be getting a new card soon and hope the new one is not going to cause driver issues.

Cheers!

_________________
Image
Image
Image


22 Mar 2014, 00:56
Profile
Senior Member
User avatar

Joined: 13 Mar 2011, 23:02
Posts: 678
Glad it helped. :P

As a ide note, next time you need technical support, please use the forum with the same name, which is more appropriate.
The 'SWAT' forum is intended to be 'general speaking' about the game, being the default place when no better suitable one is to be found. ;-)

I moved the thread there.

_________________
Beerbelott
Image
Image
All my potential profiles (several moves, either physical or IP-based)


22 Mar 2014, 14:57
Profile
Display posts from previous:  Sort by  
This topic is locked, you cannot edit posts or make further replies.   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.